Udacity Classroom Down
Incident Report for Udacity
Resolved
The Classroom should now load correctly for everyone! If you continue to have trouble with our site, please contact us via https://www.udacity.com/contact.
Posted 10 months ago. Jul 12, 2018 - 16:36 PDT
Monitoring
The classroom should now load, but it may be slow for some students. We're continuing to monitor the situation.
Posted 10 months ago. Jul 12, 2018 - 14:47 PDT
Update
We are continuing to investigate this issue.
Posted 10 months ago. Jul 12, 2018 - 14:25 PDT
Investigating
Our Classroom is currently experiencing some loading issues, and students may not be able to access their coursework. Our crack team of engineers is investigating, and we'll update this page as we have more information. We apologize for the inconvenience, and appreciate your patience while we work to resolve this!
Posted 10 months ago. Jul 12, 2018 - 13:57 PDT
This incident affected: Classroom and Reviews.