Payment processing errors
Incident Report for Udacity
Resolved
This incident has been resolved. Our payments processor is functioning normally once again.
Posted 6 days ago. Jul 10, 2019 - 16:11 PDT
Investigating
One of our payment processing partners is experiencing elevated error rates and response times. If you are having trouble purchasing Udacity courses at this time we ask you to return later today.
Posted 6 days ago. Jul 10, 2019 - 14:48 PDT
This incident affected: Checkout.