www.udacity.com down
Incident Report for Udacity
Resolved
The outage has been resolved, and our engineers are investigating what happened. We apologize for the inconvenience! If you're still having trouble with the site, please contact us via our Contact Page: https://www.udacity.com/contact.
Posted 3 months ago. Sep 25, 2017 - 13:55 PDT
Investigating
Our website is down at the moment and we are investigating the issue. We will update this page as soon as we have more information, and we sincerely apologize for the inconvenience!
Posted 3 months ago. Sep 25, 2017 - 13:43 PDT