Checkout Errors
Incident Report for Udacity
Resolved
This incident has been resolved.
Posted Apr 20, 2020 - 18:32 PDT
Investigating
We are currently investigating a problem with the Udacity Checkout page.
Posted Apr 20, 2020 - 18:17 PDT
This incident affected: Checkout.