Projects cannot be submitted for Reviews
Incident Report for Udacity
Resolved
Project submission is working as expected.
Posted 4 months ago. Aug 20, 2018 - 16:57 PDT
Investigating
We are investigating an outage in our Reviews system and will update as soon as we have an ETA for resolution.
Posted 4 months ago. Aug 20, 2018 - 16:45 PDT
This incident affected: Reviews.