New Enrollment Errors
Incident Report for Udacity
Resolved
We have identified the issue and it has been resolved. Thank you for your patience.
Posted over 1 year ago. May 24, 2016 - 13:41 PDT
Investigating
We received reports that students cannot enroll in certain Nanodegree programs. We are currently investigating the problem.
Posted over 1 year ago. May 24, 2016 - 10:35 PDT