blog.udacity.com is down
Incident Report for Udacity
Resolved
Our blog is back up :)
Posted almost 2 years ago. Oct 20, 2015 - 22:25 PDT
Identified
The service provider for our blog is undergoing scheduled maintenance. We are monitoring and hope to be back soon.
Posted almost 2 years ago. Oct 20, 2015 - 22:21 PDT